[易语言] 滴答表格挂接事件 : 事件编号

仅记录; 个人不推荐使用滴答. 太多问题了. 并且早已停止更新了

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
.程序集变量 黑月OCX, 黑月COM类, , , 
.子程序 _DDiDaPG_挂接事件
黑月OCX.挂接事件 (1, &_DDiDaPG_GridMouseMove, 0)
黑月OCX.挂接事件 (2, &_DDiDaPG_GridDragOver, 0)
黑月OCX.挂接事件 (3, &_DDiDaPG_GridSelectRange, 0)
黑月OCX.挂接事件 (4, &_DDiDaPG_GridLClickUp, 0)
黑月OCX.挂接事件 (5, &_DDiDaPG_GridDblClick, 0)
黑月OCX.挂接事件 (6, &_DDiDaPG_GridKeyPress, 0)
黑月OCX.挂接事件 (7, &_DDiDaPG_GridMouseWheel, 0)
黑月OCX.挂接事件 (8, &_DDiDaPG_GridRClickUp, 0)
黑月OCX.挂接事件 (9, &_DDiDaPG_GridCellEndEdit, 0)
黑月OCX.挂接事件 (10, &_DDiDaPG_GridTreeExpand, 0)
黑月OCX.挂接事件 (11, &_DDiDaPG_GridTreeCollapse, 0)
黑月OCX.挂接事件 (12, &_DDiDaPG_GridCellBtnLClickUp, 0)
黑月OCX.挂接事件 (13, &_DDiDaPG_GridCellBtnLClickDown, 0)
黑月OCX.挂接事件 (14, &_DDiDaPG_GridVScroll, 0)
黑月OCX.挂接事件 (15, &_DDiDaPG_GridHScroll, 0)
黑月OCX.挂接事件 (16, &_DDiDaPG_GridCellComboSelChange, 0)
黑月OCX.挂接事件 (17, &_DDiDaPG_GridRowResize, 0)
黑月OCX.挂接事件 (18, &_DDiDaPG_GridCellStartEdit, 0)
黑月OCX.挂接事件 (19, &_DDiDaPG_GridColumnResize, 0)
黑月OCX.挂接事件 (20, &_DDiDaPG_GridBeginPrint, 0)
黑月OCX.挂接事件 (21, &_DDiDaPG_GridBeginPreview, 0)
黑月OCX.挂接事件 (22, &_DDiDaPG_GridFinishPreview, 0)
黑月OCX.挂接事件 (23, &_DDiDaPG_GridFinishPrint, 0)
黑月OCX.挂接事件 (24, &_DDiDaPG_GridCellCheckBoxChecked, 0)
黑月OCX.挂接事件 (25, &_DDiDaPG_GridOnChar, 0)
黑月OCX.挂接事件 (26, &_DDiDaPG_GridMenuStart, 0)
黑月OCX.挂接事件 (27, &_DDiDaPG_GridMenuCommand, 0)
黑月OCX.挂接事件 (28, &_DDiDaPG_GridCellCGSelChange, 0)
黑月OCX.挂接事件 (29, &_DDiDaPG_RowDragOver, 0)
黑月OCX.挂接事件 (30, &_DDiDaPG_ColDragOver, 0)
黑月OCX.挂接事件 (31, &_DDiDaPG_GridCellChanged, 0)

.子程序 _DDiDaPG_GridMouseMove, , , 事件编号: 1
.参数 用户数据, 整数型
.参数 nFlags, 整数型, ,
.参数 x, 整数型, ,
.参数 y, 整数型, ,
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,

.子程序 _DDiDaPG_GridDragOver, , , 事件编号: 2
.参数 用户数据, 整数型
.参数 nFlags, 整数型, ,
.参数 x, 整数型, ,
.参数 y, 整数型, ,
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,

.子程序 _DDiDaPG_GridSelectRange, , , 事件编号: 3
.参数 用户数据, 整数型
.参数 nMinRow, 整数型, ,
.参数 nMinCol, 整数型, ,
.参数 nMaxRow, 整数型, ,
.参数 nMaxCol, 整数型, ,

.子程序 _DDiDaPG_GridLClickUp, , , 事件编号: 4
.参数 用户数据, 整数型
.参数 nFlags, 整数型, ,
.参数 x, 整数型, ,
.参数 y, 整数型, ,
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,

.子程序 _DDiDaPG_GridDblClick, , , 事件编号: 5
.参数 用户数据, 整数型
.参数 nFlags, 整数型, ,
.参数 x, 整数型, ,
.参数 y, 整数型, ,
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,

.子程序 _DDiDaPG_GridKeyPress, , , 事件编号: 6
.参数 用户数据, 整数型
.参数 nChar, 整数型, 参考,
.参数 nFlags, 整数型, ,

.子程序 _DDiDaPG_GridMouseWheel, , , 事件编号: 7
.参数 用户数据, 整数型
.参数 nFlags, 整数型, ,
.参数 nDelta, 短整数型, ,

.子程序 _DDiDaPG_GridRClickUp, , , 事件编号: 8
.参数 用户数据, 整数型
.参数 nFlags, 整数型, ,
.参数 x, 整数型, ,
.参数 y, 整数型, ,
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,

.子程序 _滴答事件_结束编辑单元格, , , 事件编号: 9 GridCellEndEdit
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 nType, 整数型, ,

.子程序 _DDiDaPG_GridTreeExpand, , , 事件编号: 10
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 bCanExpand, 短整数型, 参考,
.参数 nExpandFlags, 整数型, 参考,

.子程序 _DDiDaPG_GridTreeCollapse, , , 事件编号: 11
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 bCanCollapse, 短整数型, 参考,

.子程序 _DDiDaPG_GridCellBtnLClickUp, , , 事件编号: 12
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 nIndex, 整数型, ,
.参数 nState, 整数型, ,

.子程序 _DDiDaPG_GridCellBtnLClickDown, , , 事件编号: 13
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 nIndex, 整数型, ,
.参数 nState, 整数型, ,

.子程序 _DDiDaPG_GridVScroll, , , 事件编号: 14
.参数 用户数据, 整数型
.参数 nTopRow, 整数型, ,
.参数 nLeftCol, 整数型, ,
.参数 nSBCode, 整数型, ,

.子程序 _DDiDaPG_GridHScroll, , , 事件编号: 15
.参数 用户数据, 整数型
.参数 nTopRow, 整数型, ,
.参数 nLeftCol, 整数型, ,
.参数 nSBCode, 整数型, ,

.子程序 _DDiDaPG_GridCellComboSelChange, , , 事件编号: 16
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 nSelIndex, 整数型, ,
.参数 strText, 文本型, ,

.子程序 _DDiDaPG_GridRowResize, , , 事件编号: 17
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 bCanResize, 短整数型, 参考,

.子程序 _滴答事件_开始编辑单元格, , , 事件编号: 18
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 nType, 整数型, ,
.参数 bCanEdit, 短整数型, 参考,

.子程序 _DDiDaPG_GridColumnResize, , , 事件编号: 19
.参数 用户数据, 整数型
.参数 nCol, 整数型, ,
.参数 bCanResize, 短整数型, 参考,

.子程序 _DDiDaPG_GridBeginPrint, , , 事件编号: 20
.参数 用户数据, 整数型

.子程序 _DDiDaPG_GridBeginPreview, , , 事件编号: 21
.参数 用户数据, 整数型
.参数 iViewType, 短整数型, ,

.子程序 _DDiDaPG_GridFinishPreview, , , 事件编号: 22
.参数 用户数据, 整数型
.参数 iViewType, 短整数型, ,

.子程序 _DDiDaPG_GridFinishPrint, , , 事件编号: 23
.参数 用户数据, 整数型

.子程序 _DDiDaPG_GridCellCheckBoxChecked, , , 事件编号: 24
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 iChecked, 短整数型, ,

.子程序 _DDiDaPG_GridOnChar, , , 事件编号: 25
.参数 用户数据, 整数型
.参数 nChar, 整数型, 参考,
.参数 nFlags, 整数型, ,

.子程序 _DDiDaPG_GridMenuStart, , , 事件编号: 26
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 iSelection, 短整数型, ,

.子程序 _DDiDaPG_GridMenuCommand, , , 事件编号: 27
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 nMenuID, 整数型, ,

.子程序 _DDiDaPG_GridCellCGSelChange, , , 事件编号: 28
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 nChildRow, 整数型, ,
.参数 nChildCol, 整数型, ,
.参数 strText, 文本型, ,

.子程序 _DDiDaPG_RowDragOver, , , 事件编号: 29
.参数 用户数据, 整数型
.参数 nSrcRow, 整数型, ,
.参数 nDestRow, 整数型, ,
.参数 iAllow, 短整数型, 参考,

.子程序 _DDiDaPG_ColDragOver, , , 事件编号: 30
.参数 用户数据, 整数型
.参数 nSrcCol, 整数型, ,
.参数 nDestCol, 整数型, ,
.参数 iAllow, 短整数型, 参考,

.子程序 _DDiDaPG_GridCellChanged, , , 事件编号: 31
.参数 用户数据, 整数型
.参数 nRow, 整数型, ,
.参数 nCol, 整数型, ,
.参数 nType, 整数型, ,